Welcome to our new website! Some content may have moved. If you can’t find what you need, try our search or get in touch and we’ll be happy to help.

Speak to a website designer — call Call 01793 239239 Our team are here 9am to 5pm weekdays Client Connect

The Digital Insider Blog

New requirement for WooCommerce 6.5

New requirement for WooCommerce 6.5

WooCommerce also depends on a number of third-party packages — and many of those are gradually dropping support for older PHP versions.

It’s been a while since WooCommerce bumped the minimum PHP version of WooCommerce to 7.0, and the WooCommerce team believes that now is about time for a new bump. Starting with version 6.5, scheduled for release in May 2022, WooCommerce will require PHP 7.2 or newer to work.

Why this change?

The PHP ecosystem is evolving rapidly. At the time of writing this, the only actively maintained versions of PHP are 8.0 and 8.1; PHP 7.4 entered “security fixes only” mode and PHP 7.3 went unsupported as of December 2021. WordPress recommends at least PHP 7.4 for performance and security reasons, and these reasons are even more important on an e-commerce site.

WooCommerce also depends on a number of third-party packages — and many of those are gradually dropping support for older PHP versions. This is already causing issues, as it’s increasingly hard to find packages that support all the range of PHP versions from 7.0 to 8.1.

Why 7.2 specifically? This is the oldest version that still has a significant number of WooCommerce installs running according to data collected by the WooCommerce team:

New requirement for WooCommerce 6.5

Note that of all the sites running on PHP 7.0 or 7.1, only about half seem to be actively maintained — that is, running a WooCommerce version that is at most six months old.

What happens if I don’t upgrade?

If your server is still on PHP 7.0 or 7.1 by the time WooCommerce 6.5 is published, your WooCommerce instance will continue working, but you won’t be able to upgrade past WooCommerce 6.4 (or any 6.4.x maintenance release published afterwards).

The WooCommerce team strongly recommend upgrading your servers to at least PHP 7.4 in order to keep your WooCommerce sites up to date, performant, and secure.

Keep reading

Related posts

Need a hand with your website?

Get in touch and we'll be happy to help — no tricks, traps or technobabble.