January 2020 will see new minimum requirements for WooCommerce 3.9

When WooCommerce 3.9 is released in January, it will have new required versions of WordPress and PHP. Running WooCommerce 3.9 will require a site running WordPress 5.0 and PHP 7.0 or newer.

The WooCommerce development team plan to keep developing blocks and other integrations that rely on current versions of WordPress, and this release prepare WooCommerce for these new features so we can deliver the best experience for our users. A very small percentage of WooCommerce stores run versions of WordPress and PHP older than these requirements, so impact, according to the WooCommerce team, will be minimal.

What does it mean for your store if your site is affected?

Simply put, you will not be able to update to WooCommerce 3.9 when it gets released, so WordPress will not offer you the update. If you’re among these sites, the WooCommerce team has created a document explaining the benefits of updating to newer versions of WordPress and PHP that includes instructions on how to safely update.