woocommerce-33-now-available.jpg

Time to upgrade! WooCommerce 4.8 is now available!

The WoocCommerce team has announced the release of WooCommerce 4.8, which is now publicly available! It has been in development since November 2020 and Core contributions include about 257 commits from 29 contributors. This is a minor release, which means everything is backward compatible with the previous version. Given the release of PHP8, WordPress 5.6, and the Twenty Twenty-One theme, the...
Read More

WooCommerce: Spam Orders and Accounts from Bots

Versions of WooCommerce prior to 4.6.2 contain a vulnerability that allows guest users to create accounts during checkout even when the "Allow customers to create an account during checkout" setting is disabled. This vulnerability is being exploited by a bot to place spam orders and create user accounts that are then used to probe for vulnerabilities in other plugins on the site. In response to...
Read More

WooCommerce 4.0 is now available, but is not fully backwards compatible

WooCommerce 4.0 is a “major” release. This means that this version is not fully backwards compatible with sites running various versions of WooCommerce 3.x. Therefore, we recommend testing the upgrade on a staging site copy before upgrading your live store and creating a backup of your code and database. Please see this guide on the WooCommerce website for more details. What’s new in...
Read More

Important changes in WooCommerce 3.9 to MaxMind Geolocation and PHP minimum requirements

The WooCommerce development team has announced the official release of WooCommerce 3.9. WooCommerce 3.9 has been in development since November 2019 and contains around 600 commits from 18 contributors. This release is classed as a "minor release, which means everything should be backward compatible with previous versions of WooCommerce. Even though it’s a minor release, as always, we recommend...
Read More
woocommerce-33-now-available.jpg

January 2020 will see new minimum requirements for WooCommerce 3.9

When WooCommerce 3.9 is released in January, it will have new required versions of WordPress and PHP. Running WooCommerce 3.9 will require a site running WordPress 5.0 and PHP 7.0 or newer. The WooCommerce development team plan to keep developing blocks and other integrations that rely on current versions of WordPress, and this release prepare WooCommerce for these new features so we can deliver...
Read More

Time to update – WooCommerce 3.8 is here! 🎉

The WooCommerce team has announced that WooCommerce 3.8 is now live and ready to be installed! This final minor release for 2019 has been tested rigorously by WooCommerce team of developers along with real-life store owners. It should be fully backward compatible with all WooCommerce releases since 3.0 and represents a move towards smaller, stable, and more frequent releases. Here's what's new in...
Read More

Wishlists let customers tell you what they want to buy from your store

Wishlists are one of the few instances in eCommerce websites when customers tell you exactly what they want — but don't yet have — from your online store. This demonstrated interest presents a highly-valuable opportunity to make a sale and fulfill a customer need, but it is often underutilised as a marketing tool. Here are our top 5 ways to turn customer wishlists into sales and increase...
Read More

Before updating to WordPress 5.0, make sure you’re running WooCommerce 3.5.1+

When WordPress 5.0 is released this month – currently planned for November 19 – your site needs to be running WooCommerce 3.5.1+ to avoid breaking changes. This is even more important if you have auto-updates toggled on. Since the last minor release of WooCommerce in May, the WooCommerce team have been working on a variety of improvements: Performance improvements REST API v3 Improved wording...
Read More
time-to-upgrade-woocommerce-32-is-now-available.jpg

WooCommerce 3.4.6 released this week, patches security bug

This past week WooCommerce developers have released version 3.4.6. This release patches a security issue for all previous versions and it's strongly recommended that you to update your WooCommerce sites as soon as possible. Versions 3.4.5 and earlier are affected by a handful of issues that allow Shop Managers to exceed their capabilities and perform malicious actions. These issues can be...
Read More

WooCommerce 3.4 is now available with GDPR compliance features for your store

WooCommerce, the popular eCommerce plugin for WordPress is now available, after having been in development since January, and includes some essential tools relating to GDPR compliance and your website. While 3.4 is a “minor” release; meaning this version should be backwards compatible with sites running versions of WooCommerce greater than 3.0. It's still recommend that your site is tested...
Read More